The CPU usage is now consistently much, much lower than before. We are back in business!
Posted Apr 06, 2026 - 08:56 PDT
Update
We have applied further fixes today and we are now seeing a much more significant drop in CPU usage. Continuing to monitor.
Posted Apr 06, 2026 - 02:52 PDT
Update
It looks like there may be some lingering speed issues from the bot activity. We are more stable now for sure, but may need to apply additional fixes over the next 24 hours.
Posted Apr 05, 2026 - 05:34 PDT
Monitoring
We have applied the necessary fixes. CPU usage has dropped dramatically but we are continuing to monitor it in case further fixes are required.
Posted Apr 05, 2026 - 05:27 PDT
Identified
We have identified the problem as being due to database locks and bot activity. We have applied some database repairs and are now preparing to block the bots.
Posted Apr 05, 2026 - 05:18 PDT
Investigating
Our server is currently experiencing degraded performance which may be affecting website speed and could result in temporary site outages. We are currently investigating the cause in order to find a fix.
Posted Apr 05, 2026 - 04:44 PDT
This incident affected: Website and Pattern Maker.